eD2k Link Selector - 电驴链接插件for Discuz! X2 v4.2

Discuz!版电驴链接插件(eD2k链接,eMule链接)是基于WordPress插件eD2k Link Selector制作的。由于本人水平很业余,如果你在使用中出现任何问题请来此处反馈。

主要功能

支持[ed2k][/ed2k]和[emule][/emule]标签的转换,也支持没有被这两种标签包含的ed2k链接的自动转换,支持论坛程序Discuz! 版本X2。请一定要注意。
应大家需求,第三版同时支持简体中文GBK版 和 UTF8版,请安装时注意安装符合自己论坛编码的版本。

支持功能:管理员后台设置属性预设,编辑器按钮,文件名过滤器,文件大小过滤器。
目前不支持:语言切换,标签自定义属性,后台预览,样式设计(你可以手动修改和设计ed2k-link-selector-php下的ed2kls.css样式文件)。

下载与使用

此插件为应网友需求而免费制作,如果你在此基础上修改,请保留和尊重原始插件底部的主页链接

googlecode下载:discuz-ed2k-link-selector-for-x2-v4.2
discuz官方下载:discuz-ed2k-link-selector-for-x2-v4.2

插件版本:for Discuz! X2 [v4.2]
基于eD2k Link Selector 版本:1.1.7
协议:GPL v2
最后更新时间:2012年03月14日

使用方法:使用方法:
1.上传到ed2k文件夹到插件目录;
2.在后台安装插件,请根据你使用的语言编码选择“简体中文”或“简体中文UTF8版”;
3.启用插件,在这里你可以设置你希望的显示效果和功能。

新功能
v4版本提供了编辑器按钮摆放位置的设置。

可以设置的区域有如图所示:

Discuz! X2 电驴链接插件

插入区域

可以选择放置在区域头部或尾部:

Discuz! X2 电驴链接插件

插入位置

安装问题

如果安装以后出现链接混乱,文件名处显示“ onclick="ed2kls......”等等等等,这是因为插件安装程序没有对 function_discuzcode.php 文件的修改权限,导致了discuz自带的ed2k链接解析继续生效,如果出现此情况,

只需要找到文件:source/function/function_discuzcode.php,打开文件找到以下字符串:

/ed2k:\/\/(.+?)\//e

替换为

/deprecated_ed2k:\/\/(.+?)\//e

保存即可,注意做好备份。如果卸载后出现ed2k不解析问题则同理反操作即可。

其他问题

可能出现的问题:

1.可能你还使用了一些其他会涉及到帖子内容改变的插件,比如:关键字链接插件,由于本插件使用了function_discuzcode的嵌入点,该嵌入点位置在前,所以有可能会被其他插件再次转换,破坏结果,如果有这样的情况,请用排除法找到该插件,然后告诉我,我帮你想办法。

2.此问题在v4.2版本已解决
如果你发布的文件ed2k链接里带有网站地址一类的信息,会导致discuz自动链接识别功能将其转换成http超链接而出现混乱。
解决办法:删除掉链接中的网站地址,或者发布帖子的时候禁用链接识别(推荐)。

使用效果

Discuz! X2 电驴链接插件

前台效果

Discuz! X2 电驴链接插件

后台设置

50条评论隐藏

  1. #1 lce橙子
    2011年12月16日 周五 18:57 | 回复

    楼主 能否给个GBK版本的啊 :cry:

  2. #2 uralhan
    2011年12月16日 周五 19:55 | 回复

    @lce橙子 哦,我还以为现在都用utf-8了,有空加个GBK版本的。

  3. #3 housan
    2011年12月17日 周六 12:17 | 回复

    我的站也是GBK的,很期待GBK版本的

  4. 2011年12月17日 周六 13:47 | 回复

    你早说会出DZ插件我就不去那么麻烦的修改了~~

  5. 2011年12月17日 周六 20:17 | 回复

    强力需求。。。GBK X2版本!

  6. #6 mier
    2011年12月19日 周一 14:47 | 回复

    GBK版本电驴链接插件有了

  7. 2011年12月19日 周一 16:33 | 回复

    gbk版安装后不能用了 附件 图片按钮要失效了 不知道怎么回事

  8. #8 mier
    2011年12月19日 周一 17:27 | 回复

    @zxcvbn554 好像要更新缓存吧?

  9. 2011年12月20日 周二 13:17 | 回复

    gbk版安装后不能用了 附件 图片 视频 还有自丁的迅雷下载 和快播 按钮要失效了,只有QQ表情可以用,我知道是JS的问题。我希望可以大大滴修改!!!

  10. #10 mier
    2011年12月21日 周三 15:45 | 回复

    @等待 又更新了

  11. #11 tomchen1989
    2011年12月24日 周六 13:09 | 回复

    @ylsnuha 这几个不是我搞的。。。

  12. #12 酷派天空
    2012年1月12日 周四 15:05 | 回复

    编辑器里点电驴图标。出现输入框 让我输入ED2K 连接。但是不知道为什么。输入框里默认 存在 这段字符。。懂的人可以删掉。但是对不懂的用户。这个会误导的。请问怎么解决呢

  13. #13 酷派天空
    2012年1月12日 周四 15:07 | 回复

    补充一下。在火狐浏览器里
    就没问题。没多出 body 字符

  14. #14 uralhan
    2012年1月12日 周四 15:52 | 回复

    @酷派天空 安装的什么版本?GBK还是utf-8?出现什么字符呢? IE6没有问题,什么浏览器会出现的?

  15. 2012年1月16日 周一 15:47 | 回复

    为什么我装完GBK版的之后前台所有页面都打不开,全是空白的,停用插件就好了。

  16. #16 mier
    2012年1月16日 周一 16:03 | 回复

    @方坤 可能是插件冲突吧,有的插件也会修改bbcode文件,你可以自己备份一个function_discuzcode.php文件,安装这个插件以后还原,然后手动修改。找到
    /ed2k:\/\/(.+?)\//e
    替换为
    /deprecated_ed2k:\/\/(.+?)\//e

  17. 2012年1月17日 周二 10:11 | 回复

    @mier 按照你说的试了一下,还是不行。我卸载后安装了一遍utf-8版本的没有出现页面前台页面打不开的问题。不知道现在是何问题,求帮助。

  18. #18 mier
    2012年1月17日 周二 10:27 | 回复

    @方坤 是不是你的编码问题,编码不同吧?我建议你本地测试好了再上。

  19. #19 mier
    2012年1月17日 周二 10:28 | 回复

    @方坤 我看了很多人都用了没问题,你的版本是x2吗?

  20. 2012年1月17日 周二 20:10 | 回复

    @mier 是X2最新版本。

  21. #21 利嚄
    2012年1月17日 周二 22:06 | 回复

    @方坤 肯定是插件冲突了吧

  22. 2012年1月17日 周二 23:43 | 回复

    @利嚄 应该是的,但找不到原因。只好放弃了。。。

  23. #23 利嚄
    2012年1月17日 周二 23:45 | 回复

    @方坤 用排除法,很好找原因的。

  24. #24 酷派天空
    2012年1月20日 周五 15:09 | 回复

    @uralhan IE9 GBK版本 火狐就没问题

  25. #25 心在
    2012年2月14日 周二 10:37 | 回复

    我发布多个下载地址 为什么都是单独的下载框啊 而不是可以在一个框呢

  26. #26 kerl
    2012年2月14日 周二 10:42 | 回复

    @心在 你的使用方法不对吧?看这里的说明:http://emulefans.com/wordpress-ed2k-link-selector/

  27. 2012年2月20日 周一 01:01 | 回复

    discuz官方下载:discuz-ed2k-link-selector-for-x2-v4.1

    用隐藏代码 隐藏不住 已隐藏就都没了

  28. #28 mier
    2012年2月20日 周一 09:13 | 回复

    @程旭 可以隐藏呀,代码要这样写,用隐藏代码把ed2k代码包括起来:
    [hide=1000][ed2k]ed2k://|file|eMule.2052.chm.[emulefans.com].zip|5114897|9E62078492F8D2A6E17E7C86383A47E1|h=VT4BUK6ICJL2CCFSMVFR766G7V7O5CXU|/[/ed2k][/hide]

  29. 2012年2月20日 周一 16:18 | 回复

    @mier 我说的是回复隐藏,我的帖子有的可以正常显示,有的不行 不行的整个帖子内容都没有

  30. #30 wangzczg
    2012年2月21日 周二 20:02 | 回复

    求作者开发一个支持phpcmsv9的 插件吧,如果可以的话,将会使emule走向更光明的路

  31. #31 wangzczg
    2012年2月24日 周五 16:08 | 回复

    求有相同功能的phpwind8.7 GBK 版的插件

  32. #32 酷派天空
    2012年3月21日 周三 14:39 | 回复

    @uralhan 4.2版本IE9 还是会多一个body出来

  33. 2012年4月4日 周三 15:27 | 回复

    请问一下,我用采集器发布ed2k链接的话,需要一个,发布自定义变量,请问这个变量时ed2k吗。不是的话,怎么修改,我的站www.emulecd.com,请指正.盼复!

  34. 2012年4月19日 周四 12:36 | 回复

    DZ论坛已经升级到2.5了 插件也不好用了 希望能改进 谢谢老大

  35. 2012年5月1日 周二 09:08 | 回复

    请问支持2.5么?

  36. #36 小小小诸葛
    2012年5月1日 周二 13:34 | 回复

    360浏览器下也会多出个 标签,如果不管他,直接在标签前、后插入ed2k链接,都没问题,全部删除插入链接也没有问题,但是删除一部分插入就不行。

    谷歌浏览器下正常

  37. #37 小小小诸葛
    2012年5月1日 周二 13:35 | 回复

    360浏览器下也会多出个 标签,如果不管他,直接在标签前、后插入ed2k链接,都没问题,全部删除插入链接也没有问题,但是删除一部分插入就不行。

    谷歌浏览器下正常

  38. #38 小小小诸葛
    2012年5月1日 周二 13:37 | 回复

    eMule fans 电骡爱好者 Logo

  39. 2012年8月8日 周三 22:11 | 回复

    那个高人弄个2.5的撒

  40. #40 开心宝
    2012年8月20日 周一 17:16 | 回复

    请问 是否还在开发DZ使用的ED2K插件呢 现在DZ已经升级到2.5版本了 是否还做升级版的插件呢 请问!

  41. #41 昏迷 ~
    2012年8月20日 周一 20:37 | 回复

    大大帮帮忙 ... dz 2.5 繁体 UTF8 ....... 无法安装 !!!

  42. 2012年9月16日 周日 11:13 | 回复

    运行良好

  43. #43 eds.6te.net
    2013年7月23日 周二 17:38 | 回复

    不知道您还更X3版的吗?

  44. #44 niu
    2013年10月5日 周六 14:59 | 回复

    楼猪能提供一个Discuz x3.0和3.1版本的电驴插件吗。之前2.5一直用你这个,现在网站升级了,不能用了

  45. #45 Niu
    2013年12月1日 周日 21:59 | 回复

    强烈建议 博主更新到Discuz X3.1

  46. #46 Kin
    2014年11月30日 周日 23:22 | 回复

    很好用的插件,希望可以继续更新。现在DZ 已经升级至X3.2

  47. #47 Bomber
    2014年12月1日 周一 10:31 | 回复

    隐藏设置?请问要在插件哪里设置才能有这样的效果?

  48. #48 Bomber
    2014年12月1日 周一 11:22 | 回复

    还有就是要怎么设置才能限制发帖,也就是只有管理组才有发这种帖子的权限,用户组是不能发这种帖子的

  49. 2016年1月25日 周一 11:53 | 回复

    为什么不更新新版本了?
    安装以后出现链接混乱,文件名处显示“ onclick="ed2kls......”等等等等
    还是没有解决~

  50. 2016年1月25日 周一 12:06 | 回复

    新版论坛乱码~找到问题了~内链关键字的问题~不是插件问题~

发表评论

您的Email将不会显示出来。头像请至Gravatar.com注册上传。*号标注项为必填。

如果您想输入中文却暂时没有中文输入法程序,可以使用在线的

*
*
*
标签用法
表情:
:mrgreen: :| :twisted: :arrow: 8O :) :? 8) :evil: :D :idea: :oops: :P :roll: ;) :cry: :o :lol: :x :( :!: :?:
字数:0